Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Zope2
  4. ›
  5. CVE-2009-5145

CVE-2009-5145: Zope Cross-site scripting (XSS) vulnerability in ZMI pages

May 2, 2022 (updated November 21, 2024)

Cross-site scripting (XSS) vulnerability in ZMI pages that use the manage_tabs_message in Zope 2.11.4, 2.11.2, 2.10.9, 2.10.7, 2.10.6, 2.10.5, 2.10.4, 2.10.2, 2.10.1, 2.12.

References

  • bugs.launchpad.net/zope2/+bug/490514
  • github.com/advisories/GHSA-5r4x-qc7q-vj27
  • github.com/pypa/advisory-database/tree/main/vulns/zope/PYSEC-2017-148.yaml
  • github.com/zopefoundation/Zope
  • github.com/zopefoundation/Zope/commit/2abdf14620f146857dc8e3ffd2b6a754884c331d
  • nvd.nist.gov/vuln/detail/CVE-2009-5145
  • security-tracker.debian.org/tracker/CVE-2009-5145

Code Behaviors & Features

Detect and mitigate CVE-2009-5145 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.12.5

Fixed versions

  • 2.12.5

Solution

Upgrade to version 2.12.5 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/Zope2/CVE-2009-5145.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:27 +0000.