CVE-2024-25723: ZenML Server Remote Privilege Escalation Vulnerability
(updated )
ZenML Server in the ZenML package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
References
- github.com/advisories/GHSA-vf7j-cmrj-pmmm
- github.com/zenml-io/zenml
- github.com/zenml-io/zenml/compare/0.42.1...0.42.2
- github.com/zenml-io/zenml/compare/0.43.0...0.43.1
- github.com/zenml-io/zenml/compare/0.44.3...0.44.4
- nvd.nist.gov/vuln/detail/CVE-2024-25723
- www.zenml.io/blog/critical-security-update-for-zenml-users
Code Behaviors & Features
Detect and mitigate CVE-2024-25723 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →