Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. xgrammar
  4. ›
  5. CVE-2025-58446

CVE-2025-58446: xgrammar vulnerable to denial of service by huge enum grammar

September 5, 2025 (updated November 10, 2025)

Provided grammar, would fit in a context window of most of the models, but takes minutes to process in 0.1.23. In testing with 0.1.16 the parser worked fine so this seems to be a regression caused by Earley parser.

References

  • github.com/advisories/GHSA-9q5r-wfvf-rr7f
  • github.com/mlc-ai/xgrammar
  • github.com/mlc-ai/xgrammar/commit/ced69c3ad2f8f61b516cc278a342e7c644383e27
  • github.com/mlc-ai/xgrammar/security/advisories/GHSA-9q5r-wfvf-rr7f
  • nvd.nist.gov/vuln/detail/CVE-2025-58446

Code Behaviors & Features

Detect and mitigate CVE-2025-58446 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.1.23 before 0.1.24, version 0.1.23

Fixed versions

  • 0.1.24

Solution

Upgrade to version 0.1.24 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-770: Allocation of Resources Without Limits or Throttling

Source file

pypi/xgrammar/CVE-2025-58446.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:54 +0000.