Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. xgrammar
  4. ›
  5. CVE-2025-57809

CVE-2025-57809: XGrammar affected by Denial of Service by infinite recursion grammars

August 25, 2025 (updated September 10, 2025)

This issue: http://github.com/mlc-ai/xgrammar/issues/250 should have it’s own security advisory. Since several tools accept and pass user supplied grammars to xgrammar, and it is so easy to trigger it seems like a High.

References

  • github.com/advisories/GHSA-5cmr-4px5-23pc
  • github.com/mlc-ai/xgrammar
  • github.com/mlc-ai/xgrammar/commit/b943feacb5a1caf4d39de8ec3bf7c7ce066dcee5
  • github.com/mlc-ai/xgrammar/issues/250
  • github.com/mlc-ai/xgrammar/security/advisories/GHSA-5cmr-4px5-23pc
  • nvd.nist.gov/vuln/detail/CVE-2025-57809

Code Behaviors & Features

Detect and mitigate CVE-2025-57809 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.1.21

Fixed versions

  • 0.1.21

Solution

Upgrade to version 0.1.21 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-674: Uncontrolled Recursion

Source file

pypi/xgrammar/CVE-2025-57809.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:24 +0000.