Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. wsgidav
  4. ›
  5. CVE-2022-41905

CVE-2022-41905: Cross Site Scripting vulnerability in wsgidav when directory browsing is enabled

November 16, 2022 (updated November 19, 2024)

Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks.

References

  • github.com/advisories/GHSA-xx6g-jj35-pxjv
  • github.com/mar10/wsgidav
  • github.com/mar10/wsgidav/commit/e9606ab0f42f4c1a6611bc3c52de299b0aba7726
  • github.com/mar10/wsgidav/security/advisories/GHSA-xx6g-jj35-pxjv
  • github.com/pypa/advisory-database/tree/main/vulns/wsgidav/PYSEC-2022-43018.yaml
  • nvd.nist.gov/vuln/detail/CVE-2022-41905

Code Behaviors & Features

Detect and mitigate CVE-2022-41905 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 3.0.0a1 before 4.1.0

Fixed versions

  • 4.1.0

Solution

Upgrade to version 4.1.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/wsgidav/CVE-2022-41905.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:19 +0000.