Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. wmcore
  4. ›
  5. CVE-2022-34558

CVE-2022-34558: Code Injection

July 28, 2022 (updated August 4, 2022)

WMAgent v1.3.3rc2 and 1.3.3rc1, reqmgr 2 1.4.1rc5 and 1.4.0rc2, reqmon 1.4.1rc5, and global-workqueue 1.4.1rc5 allows attackers to execute arbitrary code via a crafted dbs-client package.

References

  • github.com/dmwm/WMCore/issues/11188
  • nvd.nist.gov/vuln/detail/CVE-2022-34558

Code Behaviors & Features

Detect and mitigate CVE-2022-34558 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 1.4.1

Fixed versions

  • 2.0.4

Solution

Upgrade to version 2.0.4 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

pypi/wmcore/CVE-2022-34558.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:02 +0000.