Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Werkzeug
  4. ›
  5. CVE-2016-10516

CVE-2016-10516: Pallets Werkzeug cross-site scripting vulnerability

May 14, 2022 (updated November 19, 2024)

Cross-site scripting (XSS) vulnerability in the render_full function in debug/tbtools.py in the debugger in Pallets Werkzeug before 0.11.11 (as used in Pallets Flask and other products) allows remote attackers to inject arbitrary web script or HTML via a field that contains an exception message.

References

  • github.com/advisories/GHSA-h2fp-xgx6-xh6f
  • github.com/pallets/werkzeug
  • github.com/pallets/werkzeug/commit/1034edc7f901dd645ec6e462754111b39002bd65
  • github.com/pallets/werkzeug/pull/1001
  • github.com/pypa/advisory-database/tree/main/vulns/werkzeug/PYSEC-2017-43.yaml
  • lists.debian.org/debian-lts-announce/2017/11/msg00037.html
  • nvd.nist.gov/vuln/detail/CVE-2016-10516

Code Behaviors & Features

Detect and mitigate CVE-2016-10516 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.11.11

Fixed versions

  • 0.11.11

Solution

Upgrade to version 0.11.11 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/Werkzeug/CVE-2016-10516.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:26 +0000.