Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. vllm
  4. ›
  5. GHSA-mcmc-2m55-j8jj

GHSA-mcmc-2m55-j8jj: vLLM introduced enhanced protection for CVE-2025-62164

January 8, 2026 (updated September 11, 2026)

The fix here for CVE-2025-62164 is not sufficient. The fix only disables prompt embeds by default rather than addressing the root cause, so the DoS vulnerability remains when the feature is enabled.

References

  • access.redhat.com/security/cve/CVE-2026-56340
  • bugzilla.redhat.com/show_bug.cgi?id=2491060
  • github.com/advisories/GHSA-mcmc-2m55-j8jj
  • github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-250.yaml
  • github.com/vllm-project/vllm/pull/30649
  • github.com/vllm-project/vllm/security/advisories/GHSA-mcmc-2m55-j8jj
  • nvd.nist.gov/vuln/detail/CVE-2026-56340
  • security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-56340.json
  • www.vulncheck.com/advisories/vllm-denial-of-service-via-unvalidated-multimodal-embeddings

Code Behaviors & Features

Detect and mitigate GHSA-mcmc-2m55-j8jj with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.10.2 before 0.13.0

Fixed versions

  • 0.13.0

Solution

Upgrade to version 0.13.0 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-123: Write-what-where Condition
  • CWE-20: Improper Input Validation
  • CWE-502: Deserialization of Untrusted Data
  • CWE-787: Out-of-bounds Write

Source file

pypi/vllm/GHSA-mcmc-2m55-j8jj.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:51 +0000.