Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. vllm
  4. ›
  5. GHSA-ggpf-24jw-3fcw

GHSA-ggpf-24jw-3fcw: CVE-2025-24357 Malicious model remote code execution fix bypass with PyTorch < 2.6.0

April 23, 2025

https://github.com/vllm-project/vllm/security/advisories/GHSA-rh4j-5rhw-hr54 reported a vulnerability where loading a malicious model could result in code execution on the vllm host. The fix applied to specify weights_only=True to calls to torch.load() did not solve the problem prior to PyTorch 2.6.0.

PyTorch has issued a new CVE about this problem: https://github.com/advisories/GHSA-53q9-r3pm-6pq6

This means that versions of vLLM using PyTorch before 2.6.0 are vulnerable to this problem.

References

  • github.com/advisories/GHSA-ggpf-24jw-3fcw
  • github.com/pytorch/pytorch/security/advisories/GHSA-53q9-r3pm-6pq6
  • github.com/vllm-project/vllm
  • github.com/vllm-project/vllm/security/advisories/GHSA-ggpf-24jw-3fcw
  • github.com/vllm-project/vllm/security/advisories/GHSA-rh4j-5rhw-hr54

Code Behaviors & Features

Detect and mitigate GHSA-ggpf-24jw-3fcw with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.8.0

Fixed versions

  • 0.8.0

Solution

Upgrade to version 0.8.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-1395: Dependency on Vulnerable Third-Party Component

Source file

pypi/vllm/GHSA-ggpf-24jw-3fcw.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:09 +0000.