Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. vllm
  4. ›
  5. CVE-2026-115915

CVE-2026-115915: vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE

October 28, 2026

In vLLM 0.30.0, ImageMediaIO passes attacker-controlled image bytes to Pillow’s format autodetection without restricting the accepted formats; the request’s MIME label does not constrain decoder selection. An EPS payload labeled image/png reached the host’s Ghostscript executable. On a host with Ghostscript affected by CVE-2024-29510, this exposes the known Ghostscript sandbox escape through vLLM’s image-loading path and can execute commands with the vLLM process’s privileges. A bounded marker-command payload executed through the PyPI wheel’s actual ImageMediaIO.load_base64() implementation using Debian Ghostscript 10.03.0. The loader-level execution is reproduced; the HTTP request path is source-traced but was not exercised end to end. This report concerns vLLM’s untrusted-format dispatch and does not claim a new Ghostscript vulnerability. Exploitation requires an image-capable request path, a caller able to reach it under the deployment’s authentication policy, and a vulnerable host Ghostscript build.

References

  • github.com/advisories/GHSA-h3rc-j82p-2c3h
  • github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd
  • github.com/vllm-project/vllm/pull/60022
  • github.com/vllm-project/vllm/releases/tag/v0.32.0
  • github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h
  • nvd.nist.gov/vuln/detail/CVE-2026-115915

Code Behaviors & Features

Detect and mitigate CVE-2026-115915 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.32.0

Fixed versions

  • 0.32.0

Solution

Upgrade to version 0.32.0 or above.

Impact 8.1 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-183: Permissive List of Allowed Inputs
  • CWE-20: Improper Input Validation

Source file

pypi/vllm/CVE-2026-115915.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:25 +0000.