Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. vllm
  4. ›
  5. CVE-2026-115914

CVE-2026-115914: vLLM DeepSeek-OCR image processing vulnerable to denial of service

October 28, 2026

Any vLLM deployment serving a model of the DeepSeek-OCR family — deepseek-ai/DeepSeek-OCR, deepseek-ai/DeepSeek-OCR-2, or baidu/Unlimited-OCR (whose UnlimitedOCRForCausalLM subclasses DeepseekOCRForCausalLM) — can be killed by a single unauthenticated chat request carrying an ordinary, schema-valid PNG image, under completely default server configuration.

The image model’s input validation contains a guard inherited from the upstream DeepSeek-OCR reference implementation:

References

  • github.com/advisories/GHSA-gq5q-89c7-vhvx
  • github.com/vllm-project/vllm/commit/c15672cfb49152ebf65cfd188e71b84593ec5686
  • github.com/vllm-project/vllm/pull/59417
  • github.com/vllm-project/vllm/releases/tag/v0.32.0
  • github.com/vllm-project/vllm/security/advisories/GHSA-gq5q-89c7-vhvx
  • nvd.nist.gov/vuln/detail/CVE-2026-115914

Code Behaviors & Features

Detect and mitigate CVE-2026-115914 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.11.1 before 0.32.0

Fixed versions

  • 0.32.0

Solution

Upgrade to version 0.32.0 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-617: Reachable Assertion

Source file

pypi/vllm/CVE-2026-115914.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:54 +0000.