Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. vllm
  4. ›
  5. CVE-2025-9141

CVE-2025-9141: vLLM has remote code execution vulnerability in the tool call parser for Qwen3-Coder

August 21, 2025

An unsafe deserialization vulnerability allows any authenticated user to execute arbitrary code on the server if they are able to get the model to pass the code as an argument to a tool call.

References

  • github.com/advisories/GHSA-79j6-g2m3-jgfw
  • github.com/vllm-project/vllm
  • github.com/vllm-project/vllm/commit/4594fc3b281713bd3d7634405b4a1393af40d294
  • github.com/vllm-project/vllm/pull/21396
  • github.com/vllm-project/vllm/security/advisories/GHSA-79j6-g2m3-jgfw
  • nvd.nist.gov/vuln/detail/CVE-2025-9141

Code Behaviors & Features

Detect and mitigate CVE-2025-9141 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.10.0 before 0.10.1.1

Fixed versions

  • 0.10.1.1

Solution

Upgrade to version 0.10.1.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

pypi/vllm/CVE-2025-9141.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:20 +0000.