Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. vllm
  4. ›
  5. CVE-2025-62164

CVE-2025-62164: vLLM deserialization vulnerability leading to DoS and potential RCE

November 20, 2025 (updated July 17, 2026)

A memory corruption vulnerability that leading to a crash (denial-of-service) and potentially remote code execution (RCE) exists in vLLM versions 0.10.2 and later, in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation.

Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM.

References

  • github.com/advisories/GHSA-mrw7-hf4f-83pf
  • github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-2018.yaml
  • github.com/vllm-project/vllm
  • github.com/vllm-project/vllm/commit/58fab50d82838d5014f4a14d991fdb9352c9c84b
  • github.com/vllm-project/vllm/pull/27204
  • github.com/vllm-project/vllm/security/advisories/GHSA-mrw7-hf4f-83pf
  • nvd.nist.gov/vuln/detail/CVE-2025-62164
  • pypi.org/project/vllm

Code Behaviors & Features

Detect and mitigate CVE-2025-62164 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.10.2 before 0.11.1

Fixed versions

  • 0.11.1

Solution

Upgrade to version 0.11.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-123: Write-what-where Condition
  • CWE-20: Improper Input Validation
  • CWE-502: Deserialization of Untrusted Data
  • CWE-787: Out-of-bounds Write

Source file

pypi/vllm/CVE-2025-62164.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:44 +0000.