Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. vllm
  4. ›
  5. CVE-2025-48943

CVE-2025-48943: vLLM allows clients to crash the openai server with invalid regex

May 28, 2025 (updated June 27, 2025)

A denial of service bug caused the vLLM server to crash if an invalid regex was provided while using structured output. This vulnerability is similar to GHSA-6qc9-v4r8-22xg, but for regex instead of a JSON schema.

Issue with more details: https://github.com/vllm-project/vllm/issues/17313

References

  • github.com/advisories/GHSA-9hcf-v7m4-6m2j
  • github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2025-55.yaml
  • github.com/vllm-project/vllm
  • github.com/vllm-project/vllm/commit/08bf7840780980c7568c573c70a6a8db94fd45ff
  • github.com/vllm-project/vllm/issues/17313
  • github.com/vllm-project/vllm/pull/17623
  • github.com/vllm-project/vllm/security/advisories/GHSA-9hcf-v7m4-6m2j
  • nvd.nist.gov/vuln/detail/CVE-2025-48943

Code Behaviors & Features

Detect and mitigate CVE-2025-48943 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.8.0 before 0.9.0

Fixed versions

  • 0.9.0

Solution

Upgrade to version 0.9.0 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-248: Uncaught Exception

Source file

pypi/vllm/CVE-2025-48943.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:42 +0000.