Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. vantage6
  4. ›
  5. CVE-2025-43863

CVE-2025-43863: vantage6 lacks brute-force protection on change password functionality

June 12, 2025 (updated June 8, 2026)

If attacker gets access to an authenticated session, they can try to brute-force the user password by using the change password functionality: they can call that route infinitely which will return the message that password is wrong until it is correct

References

  • github.com/advisories/GHSA-j6g5-p62x-58hw
  • github.com/pypa/advisory-database/tree/main/vulns/vantage6/PYSEC-2025-220.yaml
  • github.com/vantage6/vantage6/commit/e0f1841b310f6f610e8137db2506cf683ce154d0
  • github.com/vantage6/vantage6/security/advisories/GHSA-j6g5-p62x-58hw
  • nvd.nist.gov/vuln/detail/CVE-2025-43863

Code Behaviors & Features

Detect and mitigate CVE-2025-43863 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.11.0

Fixed versions

  • 4.11.0

Solution

Upgrade to version 4.11.0 or above.

Impact 5.6 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-307: Improper Restriction of Excessive Authentication Attempts

Source file

pypi/vantage6/CVE-2025-43863.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:18 +0000.