Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. transifex-client
  4. ›
  5. CVE-2013-7110

CVE-2013-7110: Transifex command-line client has improper certificate validation

May 17, 2022 (updated November 18, 2024)

Transifex command-line client before 0.10 does not validate X.509 certificates for data transfer connections, which allows man-in-the-middle attackers to spoof a Transifex server via an arbitrary certificate. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-2073.

References

  • github.com/advisories/GHSA-jf99-2rj4-jxrm
  • github.com/pypa/advisory-database/tree/main/vulns/transifex-client/PYSEC-2014-72.yaml
  • github.com/transifex/transifex-client
  • github.com/transifex/transifex-client/commit/e0d1f8b38ec1a24e2999d63420554d8393206f58
  • github.com/transifex/transifex-client/issues/42
  • nvd.nist.gov/vuln/detail/CVE-2013-7110

Code Behaviors & Features

Detect and mitigate CVE-2013-7110 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.10

Fixed versions

  • 0.10

Solution

Upgrade to version 0.10 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/transifex-client/CVE-2013-7110.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:03 +0000.