Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. torch
  4. ›
  5. CVE-2025-2999

CVE-2025-2999: PyTorch is vulnerable to memory corruption through its unpack_sequence function

March 31, 2025 (updated June 10, 2026)

A vulnerability was found in PyTorch 2.6.0. It has been rated as critical. Affected by this issue is the function torch.nn.utils.rnn.unpack_sequence. The manipulation leads to memory corruption. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used.

A patch is available through commit 4945180.

References

  • github.com/advisories/GHSA-vgrw-7cvw-pwgx
  • github.com/pypa/advisory-database/tree/main/vulns/torch/PYSEC-2025-193.yaml
  • github.com/pytorch/pytorch/commit/494518046816d29099b7d056a74ffa5c244fdcdd
  • github.com/pytorch/pytorch/issues/149622
  • github.com/pytorch/pytorch/issues/149622
  • nvd.nist.gov/vuln/detail/CVE-2025-2999
  • vuldb.com/?ctiid.302048
  • vuldb.com/?id.302048
  • vuldb.com/?submit.524198

Code Behaviors & Features

Detect and mitigate CVE-2025-2999 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.9.1

Fixed versions

  • 2.9.1

Solution

Upgrade to version 2.9.1 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-119: Improper Restriction of Operations within the Bounds of a Memory Buffer

Source file

pypi/torch/CVE-2025-2999.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:07 +0000.