Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. torch
  4. ›
  5. CVE-2025-2953

CVE-2025-2953: PyTorch susceptible to local Denial of Service

March 30, 2025 (updated June 8, 2026)

A vulnerability, which was classified as problematic, has been found in PyTorch 2.6.0+cu124. Affected by this issue is the function torch.mkldnn_max_pool2d. The manipulation leads to denial of service. An attack has to be approached locally. The exploit has been disclosed to the public and may be used.

References

  • github.com/advisories/GHSA-3749-ghw9-m3mg
  • github.com/pypa/advisory-database/tree/main/vulns/torch/PYSEC-2025-191.yaml
  • github.com/pytorch/pytorch/blob/main/SECURITY.md
  • github.com/pytorch/pytorch/issues/149274
  • github.com/pytorch/pytorch/issues/149274
  • nvd.nist.gov/vuln/detail/CVE-2025-2953
  • vuldb.com/?ctiid.302006
  • vuldb.com/?id.302006
  • vuldb.com/?submit.521279

Code Behaviors & Features

Detect and mitigate CVE-2025-2953 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.7.1-rc1

Fixed versions

  • 2.7.1-rc1

Solution

Upgrade to version 2.7.1-rc1 or above.

Impact 3.3 LOW

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Learn more about CVSS

Weakness

  • CWE-404: Improper Resource Shutdown or Release

Source file

pypi/torch/CVE-2025-2953.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:13 +0000.