Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. tlslite
  4. ›
  5. CVE-2015-3220

CVE-2015-3220: tlslite remote denial of service vulnerability

May 14, 2022 (updated November 18, 2024)

The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash).

References

  • bugzilla.redhat.com/show_bug.cgi?id=1254215
  • github.com/advisories/GHSA-4749-p7rx-8jjj
  • github.com/pypa/advisory-database/tree/main/vulns/tlslite/PYSEC-2017-96.yaml
  • github.com/trevp/tlslite
  • github.com/trevp/tlslite/commit/aca8d4f898b436ff6754e1a9ab96cae976c8a853
  • groups.google.com/forum/
  • nvd.nist.gov/vuln/detail/CVE-2015-3220

Code Behaviors & Features

Detect and mitigate CVE-2015-3220 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.4.9

Fixed versions

  • 0.4.9

Solution

Upgrade to version 0.4.9 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-119: Improper Restriction of Operations within the Bounds of a Memory Buffer

Source file

pypi/tlslite/CVE-2015-3220.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.