Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. thrift
  4. ›
  5. CVE-2026-41608

CVE-2026-41608: Apache Thrift Python bindings have an Improper Handling of Highly Compressed Data (Data Amplification) vulnerability

July 27, 2026 (updated September 1, 2026)

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

References

  • github.com/advisories/GHSA-6pjx-3pjc-mrj8
  • lists.apache.org/thread/7v3jhgwfbmhx42424phydlnzb109g8b9
  • lists.apache.org/thread/vwsbcwqdpwdtp8qkjo11ol6rodbfm21f
  • nvd.nist.gov/vuln/detail/CVE-2026-41608

Code Behaviors & Features

Detect and mitigate CVE-2026-41608 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.24.0

Fixed versions

  • 0.24.0

Solution

Upgrade to version 0.24.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-409: Improper Handling of Highly Compressed Data (Data Amplification)

Source file

pypi/thrift/CVE-2026-41608.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:25 +0000.