Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. tensorflow
  4. ›
  5. CVE-2022-29205

CVE-2022-29205: Use of Uninitialized Resource

May 20, 2022 (updated June 2, 2022)

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, there is a potential for segfault / denial of service in TensorFlow by calling tf.compat.v1.* ops which don’t yet have support for quantized types, which was added after migration to TensorFlow 2.x. In these scenarios, since the kernel is missing, a nullptr value is passed to ParseDimensionValue for the py_value argument. Then, this is dereferenced, resulting in segfault. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

References

  • github.com/advisories/GHSA-54ch-gjq5-4976
  • github.com/tensorflow/tensorflow/blob/f3b9bf4c3c0597563b289c0512e98d4ce81f886e/tensorflow/python/eager/pywrap_tfe_src.cc
  • github.com/tensorflow/tensorflow/blob/f3b9bf4c3c0597563b289c0512e98d4ce81f886e/tensorflow/python/eager/pywrap_tfe_src.cc
  • github.com/tensorflow/tensorflow/commit/237822b59fc504dda2c564787f5d3ad9c4aa62d9
  • github.com/tensorflow/tensorflow/releases/tag/v2.6.4
  • github.com/tensorflow/tensorflow/releases/tag/v2.7.2
  • github.com/tensorflow/tensorflow/releases/tag/v2.8.1
  • github.com/tensorflow/tensorflow/releases/tag/v2.9.0
  • github.com/tensorflow/tensorflow/security/advisories/GHSA-54ch-gjq5-4976
  • nvd.nist.gov/vuln/detail/CVE-2022-29205

Code Behaviors & Features

Detect and mitigate CVE-2022-29205 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.6.4, all versions starting from 2.7.0 before 2.7.2, all versions starting from 2.8.0 before 2.8.1

Fixed versions

  • 2.6.4
  • 2.7.2
  • 2.8.1

Solution

Upgrade to versions 2.6.4, 2.7.2, 2.8.1 or above.

Impact 5.5 MEDIUM

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-476: NULL Pointer Dereference
  • CWE-908: Use of Uninitialized Resource

Source file

pypi/tensorflow/CVE-2022-29205.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:56 +0000.