Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. tensorflow
  4. ›
  5. CVE-2021-37682

CVE-2021-37682: Use of unitialized value in TFLite

August 25, 2021 (updated November 13, 2024)

All TFLite operations that use quantization can be made to use unitialized values. For example:

const auto* affine_quantization =
reinterpret_cast<TfLiteAffineQuantization*>(
filter->quantization.params);

The issue stems from the fact that quantization.params is only valid if quantization.type is different that kTfLiteNoQuantization. However, these checks are missing in large parts of the code.

References

  • github.com/advisories/GHSA-4c4g-crqm-xrxw
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-595.yaml
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-793.yaml
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-304.yaml
  • github.com/tensorflow/tensorflow
  • github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/lite/kernels/depthwise_conv.cc
  • github.com/tensorflow/tensorflow/commit/4a91f2069f7145aab6ba2d8cfe41be8a110c18a5
  • github.com/tensorflow/tensorflow/commit/537bc7c723439b9194a358f64d871dd326c18887
  • github.com/tensorflow/tensorflow/commit/8933b8a21280696ab119b63263babdb54c298538
  • github.com/tensorflow/tensorflow/security/advisories/GHSA-4c4g-crqm-xrxw
  • nvd.nist.gov/vuln/detail/CVE-2021-37682

Code Behaviors & Features

Detect and mitigate CVE-2021-37682 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.4, all versions starting from 2.4.0 before 2.4.3, all versions starting from 2.5.0 before 2.5.1, version 2.5.0

Fixed versions

  • 2.3.4
  • 2.4.3
  • 2.5.1

Solution

Upgrade to versions 2.3.4, 2.4.3, 2.5.1 or above.

Impact 7.1 HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-908: Use of Uninitialized Resource

Source file

pypi/tensorflow/CVE-2021-37682.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:06 +0000.