Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. tensorflow
  4. ›
  5. CVE-2020-15192

CVE-2020-15192: Memory leak in Tensorflow

September 25, 2020 (updated October 28, 2024)

If a user passes a list of strings to dlpack.to_dlpack there is a memory leak following an expected validation failure: https://github.com/tensorflow/tensorflow/blob/0e68f4d3295eb0281a517c3662f6698992b7b2cf/tensorflow/c/eager/dlpack.cc#L100-L104

The allocated memory is from https://github.com/tensorflow/tensorflow/blob/0e68f4d3295eb0281a517c3662f6698992b7b2cf/tensorflow/c/eager/dlpack.cc#L256

The issue occurs because the status argument during validation failures is not properly checked: https://github.com/tensorflow/tensorflow/blob/0e68f4d3295eb0281a517c3662f6698992b7b2cf/tensorflow/c/eager/dlpack.cc#L265-L267

Since each of the above methods can return an error status, the status value must be checked before continuing.

References

  • github.com/advisories/GHSA-8fxw-76px-3rxv
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2020-272.yaml
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2020-307.yaml
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2020-115.yaml
  • github.com/tensorflow/tensorflow
  • github.com/tensorflow/tensorflow/commit/22e07fb204386768e5bcbea563641ea11f96ceb8
  • github.com/tensorflow/tensorflow/releases/tag/v2.3.1
  • github.com/tensorflow/tensorflow/security/advisories/GHSA-8fxw-76px-3rxv
  • nvd.nist.gov/vuln/detail/CVE-2020-15192

Code Behaviors & Features

Detect and mitigate CVE-2020-15192 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.2.0 before 2.2.1, version 2.2.0, all versions starting from 2.3.0 before 2.3.1, version 2.3.0

Fixed versions

  • 2.2.1
  • 2.3.1

Solution

Upgrade to versions 2.2.1, 2.3.1 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/tensorflow/CVE-2020-15192.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:47 +0000.