Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. tensorflow-gpu
  4. ›
  5. CVE-2021-37668

CVE-2021-37668: FPE in `tf.raw_ops.UnravelIndex`

August 25, 2021 (updated November 13, 2024)

An attacker can cause denial of service in applications serving models using tf.raw_ops.UnravelIndex by triggering a division by 0:

import tensorflow as tf

tf.raw_ops.UnravelIndex(indices=-1, dims=[1,0,2])

References

  • github.com/advisories/GHSA-2wmv-37vq-52g5
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-581.yaml
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-779.yaml
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-290.yaml
  • github.com/tensorflow/tensorflow
  • github.com/tensorflow/tensorflow/commit/a776040a5e7ebf76eeb7eb923bf1ae417dd4d233
  • github.com/tensorflow/tensorflow/security/advisories/GHSA-2wmv-37vq-52g5
  • nvd.nist.gov/vuln/detail/CVE-2021-37668

Code Behaviors & Features

Detect and mitigate CVE-2021-37668 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.4, all versions starting from 2.4.0 before 2.4.3, all versions starting from 2.5.0 before 2.5.1, version 2.5.0

Fixed versions

  • 2.3.4
  • 2.4.3
  • 2.5.1

Solution

Upgrade to versions 2.3.4, 2.4.3, 2.5.1 or above.

Impact 5.5 MEDIUM

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-369: Divide By Zero

Source file

pypi/tensorflow-gpu/CVE-2021-37668.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:00 +0000.