Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. tensorflow-cpu
  4. ›
  5. CVE-2022-23566

CVE-2022-23566: Out of bounds write in Tensorflow

February 9, 2022 (updated November 13, 2024)

TensorFlow is vulnerable to a heap OOB write in Grappler:

Status SetUnknownShape(const NodeDef* node, int output_port) {
shape_inference::ShapeHandle shape =
GetUnknownOutputShape(node, output_port);
InferenceContext* ctx = GetContext(node);
if (ctx == nullptr) {
return errors::InvalidArgument("Missing context");
}
ctx->set_output(output_port, shape);
return Status::OK();
}

The set_output function writes to an array at the specified index:

void set_output(int idx, ShapeHandle shape) { outputs_.at(idx) = shape; }

Hence, this gives a malicious user a write primitive.

References

  • github.com/advisories/GHSA-5qw5-89mw-wcg2
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-75.yaml
  • github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-130.yaml
  • github.com/tensorflow/tensorflow
  • github.com/tensorflow/tensorflow/blob/a1320ec1eac186da1d03f033109191f715b2b130/tensorflow/core/framework/shape_inference.h
  • github.com/tensorflow/tensorflow/blob/a1320ec1eac186da1d03f033109191f715b2b130/tensorflow/core/grappler/costs/graph_properties.cc
  • github.com/tensorflow/tensorflow/commit/97282c6d0d34476b6ba033f961590b783fa184cd
  • github.com/tensorflow/tensorflow/security/advisories/GHSA-5qw5-89mw-wcg2
  • nvd.nist.gov/vuln/detail/CVE-2022-23566

Code Behaviors & Features

Detect and mitigate CVE-2022-23566 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.5.3, all versions starting from 2.6.0 before 2.6.3, all versions starting from 2.7.0 before 2.7.1, version 2.7.0

Fixed versions

  • 2.5.3
  • 2.6.3
  • 2.7.1

Solution

Upgrade to versions 2.5.3, 2.6.3, 2.7.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-787: Out-of-bounds Write

Source file

pypi/tensorflow-cpu/CVE-2022-23566.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:41 +0000.