Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. sushy-tools
  4. ›
  5. CVE-2022-44020

CVE-2022-44020: Improper Preservation of Permissions

October 30, 2022 (updated November 7, 2023)

An issue was discovered in OpenStack Sushy-Tools through 0.21.0 and VirtualBMC through 2.2.2. Changing the boot device configuration with these packages removes password protection from the managed libvirt XML domain. NOTE: this only affects an “unsupported, production-like configuration.”

References

  • nvd.nist.gov/vuln/detail/CVE-2022-44020
  • review.opendev.org/c/openstack/sushy-tools/+/862625
  • review.opendev.org/c/openstack/virtualbmc/+/862620
  • storyboard.openstack.org/

Code Behaviors & Features

Detect and mitigate CVE-2022-44020 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.21.1

Fixed versions

  • 0.21.1

Solution

Upgrade to version 0.21.1 or above.

Impact 5.5 MEDIUM

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-281: Improper Preservation of Permissions

Source file

pypi/sushy-tools/CVE-2022-44020.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:23 +0000.