Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. supervisor
  4. ›
  5. CVE-2017-11610

CVE-2017-11610: Incorrect Default Permissions in Supervisor

May 13, 2022 (updated October 28, 2024)

The XML-RPC server in supervisor before 3.0.1, 3.1.x before 3.1.4, 3.2.x before 3.2.4, and 3.3.x before 3.3.3 allows remote authenticated users to execute arbitrary commands via a crafted XML-RPC request, related to nested supervisord namespace lookups.

References

  • access.redhat.com/errata/RHSA-2017:3005
  • github.com/Supervisor/supervisor
  • github.com/Supervisor/supervisor/blob/3.0.1/CHANGES.txt
  • github.com/Supervisor/supervisor/blob/3.1.4/CHANGES.txt
  • github.com/Supervisor/supervisor/blob/3.2.4/CHANGES.txt
  • github.com/Supervisor/supervisor/blob/3.3.3/CHANGES.txt
  • github.com/Supervisor/supervisor/issues/964
  • github.com/advisories/GHSA-x7c8-4x3h-874w
  • github.com/pypa/advisory-database/tree/main/vulns/supervisor/PYSEC-2017-41.yaml
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4GMSCGMM477N64Z3BM34RWYBGSLK466B
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DTPDZV4ZRICDYAYZVUHSYZAYDLRMG2IM
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/JXGWOJNSWWK2TTWQJZJUP66FLFIWDMBQ
  • nvd.nist.gov/vuln/detail/CVE-2017-11610
  • security.gentoo.org/glsa/201709-06
  • www.exploit-db.com/exploits/42779

Code Behaviors & Features

Detect and mitigate CVE-2017-11610 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.0.1, all versions starting from 3.1.0 before 3.1.4, all versions starting from 3.2.0 before 3.2.4, all versions starting from 3.3.0 before 3.3.3

Fixed versions

  • 3.0.1
  • 3.1.4
  • 3.2.4
  • 3.3.3

Solution

Upgrade to versions 3.0.1, 3.1.4, 3.2.4, 3.3.3 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-276: Incorrect Default Permissions

Source file

pypi/supervisor/CVE-2017-11610.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:25 +0000.