Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. spdk
  4. ›
  5. CVE-2025-57275

CVE-2025-57275: SPDK is vulnerable to buffer overflow in the NVMe-oF target component

October 1, 2025

Storage Performance Development Kit (SPDK) 25.05 is vulnerable to Buffer Overflow in the NVMe-oF target component in SPDK - lib/nvmf.

References

  • github.com/advisories/GHSA-5m5w-w2h2-fqgq
  • github.com/spdk/spdk
  • github.com/spdk/spdk/commit/8981ddb1ccaf54f85d34482a5a644e075b58cb36
  • github.com/spdk/spdk/commit/f786c6d75f5c5162363a621b24f5449c729679c9
  • nvd.nist.gov/vuln/detail/CVE-2025-57275
  • spdk.io/

Code Behaviors & Features

Detect and mitigate CVE-2025-57275 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 25.9

Fixed versions

  • 25.9

Solution

Upgrade to version 25.9 or above.

Impact 5.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H

Learn more about CVSS

Weakness

  • CWE-119: Improper Restriction of Operations within the Bounds of a Memory Buffer

Source file

pypi/spdk/CVE-2025-57275.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:28 +0000.