Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. snowflake-connector-python
  4. ›
  5. CVE-2025-24795

CVE-2025-24795: snowflake-connector-python vulnerable to insecure cache files permissions

January 29, 2025 (updated April 9, 2025)

Issue

Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. On Linux systems, when temporary credential caching is enabled, the Snowflake Connector for Python will cache temporary credentials locally in a world-readable file.

This vulnerability affects versions 2.3.7 through 3.13.0. Snowflake fixed the issue in version 3.13.1.

Vulnerability Details

On Linux, when either EXTERNALBROWSER or USERNAME_PASSWORD_MFA authentication methods are used with temporary credential caching enabled, the Snowflake Connector for Python will cache the temporary credentials in a local file. In the vulnerable versions of the Driver, this file is created with world-readable permissions.

Solution

Snowflake released version 3.13.1 of the Snowflake Connector for Python, which fixes this issue. We recommend users upgrade to version 3.13.1.

Additional Information

If you discover a security vulnerability in one of our products or websites, please report the issue to HackerOne. For more information, please see our Vulnerability Disclosure Policy.

References

  • github.com/advisories/GHSA-r2x6-cjg7-8r43
  • github.com/pypa/advisory-database/tree/main/vulns/snowflake-connector-python/PYSEC-2025-28.yaml
  • github.com/snowflakedb/snowflake-connector-python
  • github.com/snowflakedb/snowflake-connector-python/commit/3769b43822357c3874c40f5e74068458c2dc79af
  • github.com/snowflakedb/snowflake-connector-python/releases/tag/v3.13.1
  • github.com/snowflakedb/snowflake-connector-python/security/advisories/GHSA-r2x6-cjg7-8r43
  • nvd.nist.gov/vuln/detail/CVE-2025-24795

Code Behaviors & Features

Detect and mitigate CVE-2025-24795 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.3.7 before 3.13.1

Fixed versions

  • 3.13.1

Solution

Upgrade to version 3.13.1 or above.

Impact 4.4 MEDIUM

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-276: Incorrect Default Permissions

Source file

pypi/snowflake-connector-python/CVE-2025-24795.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:49 +0000.