Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. simplejson
  4. ›
  5. CVE-2014-4616

CVE-2014-4616: Improper Validation of Array Index

May 14, 2022 (updated July 27, 2022)

Array index error in the scanstring function in the _json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-dependent attackers to read arbitrary process memory via a negative index value in the idx argument to the raw_decode function.

References

  • bugs.python.org/issue21529
  • lists.opensuse.org/opensuse-updates/2014-07/msg00015.html
  • openwall.com/lists/oss-security/2014/06/24/7
  • rhn.redhat.com/errata/RHSA-2015-1064.html
  • www.securityfocus.com/bid/68119
  • bugs.debian.org/cgi-bin/bugreport.cgi?bug=752395
  • bugzilla.redhat.com/show_bug.cgi?id=1112285
  • github.com/advisories/GHSA-9772-cwx9-r4cj
  • hackerone.com/reports/12297
  • nvd.nist.gov/vuln/detail/CVE-2014-4616
  • security.gentoo.org/glsa/201503-10

Code Behaviors & Features

Detect and mitigate CVE-2014-4616 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.6.1

Fixed versions

  • 2.6.1

Solution

Upgrade to version 2.6.1 or above.

Impact 5.9 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-129: Improper Validation of Array Index

Source file

pypi/simplejson/CVE-2014-4616.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:08 +0000.