Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. signify
  4. ›
  5. CVE-2025-70887

CVE-2025-70887: Signify allows a remote attacker to escalate privileges via the signed_data.py and the context.py components

March 25, 2026 (updated March 27, 2026)

An issue in ralphje Signify before v.0.9.2 allows a remote attacker to escalate privileges via the signed_data.py and the context.py components

References

  • github.com/advisories/GHSA-p4hh-mq57-gq8x
  • github.com/mtrojnar/osslsigncode/issues/475
  • github.com/mtrojnar/osslsigncode/pull/477
  • github.com/mtrojnar/osslsigncode/releases/tag/2.11
  • github.com/ralphje/signify
  • github.com/ralphje/signify/commit/64f21c0cc06cea0536370686ca3ba7a01e4adaa8
  • github.com/ralphje/signify/issues/60
  • nvd.nist.gov/vuln/detail/CVE-2025-70887

Code Behaviors & Features

Detect and mitigate CVE-2025-70887 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.9.2

Fixed versions

  • 0.9.2

Solution

Upgrade to version 0.9.2 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-269: Improper Privilege Management

Source file

pypi/signify/CVE-2025-70887.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:51 +0000.