Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. sickrage
  4. ›
  5. CVE-2021-25926

CVE-2021-25926: Cross-site scripting in sickrage

April 20, 2021 (updated October 22, 2024)

In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the quicksearch feature. Therefore, an attacker can steal a user’s sessionID to masquerade as a victim user, to carry out any actions in the context of the user.

References

  • github.com/SiCKRAGE/SiCKRAGE
  • github.com/SiCKRAGE/SiCKRAGE/commit/9f42426727e16609ad3d1337f6637588b8ed28e4
  • github.com/advisories/GHSA-x823-j7c4-vpc5
  • github.com/pypa/advisory-database/tree/main/vulns/sickrage/PYSEC-2021-148.yaml
  • nvd.nist.gov/vuln/detail/CVE-2021-25926

Code Behaviors & Features

Detect and mitigate CVE-2021-25926 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 9.3.54 before 10.0.11.dev2

Fixed versions

  • 10.0.11.dev2

Solution

Upgrade to version 10.0.11.dev2 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/sickrage/CVE-2021-25926.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:13 +0000.