Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. sickrage
  4. ›
  5. CVE-2021-25925

CVE-2021-25925: Cross-site scripting in SiCKRAGE

April 20, 2021 (updated April 30, 2025)

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.

References

  • github.com/SiCKRAGE/SiCKRAGE
  • github.com/SiCKRAGE/SiCKRAGE/commit/9f42426727e16609ad3d1337f6637588b8ed28e4
  • github.com/advisories/GHSA-rmp7-f2vp-3rq4
  • github.com/pypa/advisory-database/tree/main/vulns/sickrage/PYSEC-2021-147.yaml
  • nvd.nist.gov/vuln/detail/CVE-2021-25925
  • www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25925

Code Behaviors & Features

Detect and mitigate CVE-2021-25925 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.2.0 before 10.0.11.dev2

Fixed versions

  • 10.0.11.dev2

Solution

Upgrade to version 10.0.11.dev2 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/sickrage/CVE-2021-25925.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:51 +0000.