Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. shuup
  4. ›
  5. CVE-2021-25963

CVE-2021-25963: Cross-site Scripting in shuup

October 4, 2021 (updated October 23, 2024)

In Shuup, versions 1.6.0 through 2.10.8 are vulnerable to reflected Cross-Site Scripting (XSS) that allows execution of arbitrary javascript code on a victim browser. This vulnerability exists due to the error page contents not escaped.

References

  • github.com/advisories/GHSA-5pcx-vqjp-p34w
  • github.com/pypa/advisory-database/tree/main/vulns/shuup/PYSEC-2021-350.yaml
  • github.com/shuup/shuup
  • github.com/shuup/shuup/commit/75714c37e32796eb7cbb0d977af5bcaa26573588
  • nvd.nist.gov/vuln/detail/CVE-2021-25963
  • www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25963

Code Behaviors & Features

Detect and mitigate CVE-2021-25963 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.6.0 before 2.11.0

Fixed versions

  • 2.11.0

Solution

Upgrade to version 2.11.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/shuup/CVE-2021-25963.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:02 +0000.