Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. setuptools
  4. ›
  5. CVE-2013-1633

CVE-2013-1633: Setuptools vulnerable to Man-in-the-middle attacks

May 17, 2022 (updated October 22, 2024)

easy_install in setuptools before 0.7 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to the default use of the product.

References

  • github.com/advisories/GHSA-27x4-j476-jp5f
  • github.com/pypa/advisory-database/tree/main/vulns/setuptools/PYSEC-2013-22.yaml
  • github.com/pypa/setuptools
  • nvd.nist.gov/vuln/detail/CVE-2013-1633
  • pypi.python.org/pypi/setuptools/0.9.8

Code Behaviors & Features

Detect and mitigate CVE-2013-1633 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.7

Fixed versions

  • 0.7

Solution

Upgrade to version 0.7 or above.

Impact 8.3 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-319: Cleartext Transmission of Sensitive Information

Source file

pypi/setuptools/CVE-2013-1633.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:58 +0000.