Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. semantic-router
  4. ›
  5. GHSA-98x5-vq43-vc5p

GHSA-98x5-vq43-vc5p: semantic-router exposed to compromised litellm wheel (CVE-2026-42208) via unbounded transitive pin

June 26, 2026

semantic-router versions 0.1.8 through 0.1.14 declare litellm>=1.61.3 with no upper bound. During the window in which litellm==1.82.8 was the latest release on PyPI, a fresh install of any affected semantic-router version could resolve to that compromised wheel.

The malicious litellm==1.82.8 wheel ships a litellm_init.pth file that executes on Python interpreter startup — no import required. It collects and exfiltrates:

  • Process environment variables
  • AWS / GCP / Azure credentials
  • SSH keys, Kubernetes configs, shell history
  • Database credentials and CI/CD secrets
  • Cryptocurrency wallets

Stage-two payload encrypts the collected data (AES-256 + embedded RSA pubkey) and POSTs it to https://models.litellm.cloud/.

See upstream: BerriAI/litellm#24512 and CVE-2026-42208.

References

  • github.com/advisories/GHSA-98x5-vq43-vc5p
  • github.com/aurelio-labs/semantic-router/security/advisories/GHSA-98x5-vq43-vc5p

Code Behaviors & Features

Detect and mitigate GHSA-98x5-vq43-vc5p with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.1.8 before 0.1.15

Fixed versions

  • 0.1.15

Solution

Upgrade to version 0.1.15 or above.

Weakness

  • CWE-506: Embedded Malicious Code

Source file

pypi/semantic-router/GHSA-98x5-vq43-vc5p.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:20 +0000.