Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. saleor
  4. ›
  5. CVE-2023-26051

CVE-2023-26051: Saleor has Staff-Authenticated Error Message Information Disclosure Vulnerability via Python Exceptions

March 3, 2023 (updated July 28, 2026)

Some internal Python exceptions are not handled properly and thus are returned in API as error messages. Some messages might contain sensitive information like user email address in staff-authenticated requests.

This issue has been patched in versions 3.1.48, 3.7.59, 3.8.30, 3.9.27, 3.10.14 and 3.11.12.

References

  • github.com/advisories/GHSA-r8qr-wwg3-2r85
  • github.com/pypa/advisory-database/tree/main/vulns/saleor/PYSEC-2026-917.yaml
  • github.com/saleor/saleor/commit/31bce881ccccf0d79a9b14ecb6ca3138d1edeec1
  • github.com/saleor/saleor/releases/tag/3.1.48
  • github.com/saleor/saleor/releases/tag/3.10.14
  • github.com/saleor/saleor/releases/tag/3.11.12
  • github.com/saleor/saleor/releases/tag/3.7.59
  • github.com/saleor/saleor/releases/tag/3.8.30
  • github.com/saleor/saleor/releases/tag/3.9.27
  • github.com/saleor/saleor/security/advisories/GHSA-r8qr-wwg3-2r85
  • nvd.nist.gov/vuln/detail/CVE-2023-26051

Code Behaviors & Features

Detect and mitigate CVE-2023-26051 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.0.0 before 3.1.48, all versions starting from 3.7.0 before 3.7.59, all versions starting from 3.8.0 before 3.8.30, all versions starting from 3.9.0 before 3.9.27, all versions starting from 3.10.0 before 3.10.14, all versions starting from 3.11.0 before 3.11.12

Fixed versions

  • 3.1.48
  • 3.7.59
  • 3.8.30
  • 3.9.27
  • 3.10.14
  • 3.11.12

Solution

Upgrade to versions 3.1.48, 3.7.59, 3.8.30, 3.9.27, 3.10.14, 3.11.12 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-209: Generation of Error Message Containing Sensitive Information

Source file

pypi/saleor/CVE-2023-26051.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:18 +0000.