Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. roundup
  4. ›
  5. CVE-2024-39124

CVE-2024-39124: Roundup Cross-site Scripting Vulnerability

July 17, 2024

In Roundup before 2.4.0, classhelpers (_generic.help.html) allow XSS.

References

  • github.com/advisories/GHSA-w8vc-cwv9-wx67
  • github.com/roundup-tracker/roundup
  • github.com/roundup-tracker/roundup/commit/860e3c8d07b05b77c6cdf5d0b6e7dbfe51b11631
  • nvd.nist.gov/vuln/detail/CVE-2024-39124
  • www.roundup-tracker.org/
  • www.roundup-tracker.org/docs/security.html

Code Behaviors & Features

Detect and mitigate CVE-2024-39124 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.4.0

Fixed versions

  • 2.4.0

Solution

Upgrade to version 2.4.0 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/roundup/CVE-2024-39124.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:05 +0000.