Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. recommender-xblock
  4. ›
  5. CVE-2018-20858

CVE-2018-20858: Cross-site scripting in recommender-xblock

August 21, 2019 (updated October 26, 2024)

Recommender before 1.3.1 allows XSS. It is possible for a learner to craft a fake resource to recommender, that includes script which could possibly steal credentials from staff if they are lured into viewing the recommended resource.

References

  • github.com/advisories/GHSA-3j5x-7ccf-ppgm
  • github.com/edx/RecommenderXBlock/pull/2
  • github.com/openedx/RecommenderXBlock
  • github.com/pypa/advisory-database/tree/main/vulns/recommender-xblock/PYSEC-2019-219.yaml
  • groups.google.com/forum/
  • nvd.nist.gov/vuln/detail/CVE-2018-20858

Code Behaviors & Features

Detect and mitigate CVE-2018-20858 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.3.1

Fixed versions

  • 1.3.1

Solution

Upgrade to version 1.3.1 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/recommender-xblock/CVE-2018-20858.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:15 +0000.