Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. rdiffweb
  4. ›
  5. CVE-2022-3362

CVE-2022-3362: rdiffweb vulnerable to Insufficient Session Expiration

November 15, 2022 (updated October 26, 2024)

Insufficient Session Expiration in GitHub repository ikus060/rdiffweb prior to 2.5.0.

References

  • github.com/advisories/GHSA-94qm-99qc-qwqj
  • github.com/ikus060/rdiffweb
  • github.com/ikus060/rdiffweb/commit/6efb995bc32c8a8e9ad755eb813dec991dffb2b8
  • github.com/pypa/advisory-database/tree/main/vulns/rdiffweb/PYSEC-2022-43000.yaml
  • huntr.dev/bounties/ca428c31-858d-47fa-adc9-2a59f8e8b2b1
  • nvd.nist.gov/vuln/detail/CVE-2022-3362

Code Behaviors & Features

Detect and mitigate CVE-2022-3362 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.5.0

Fixed versions

  • 2.5.0

Solution

Upgrade to version 2.5.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-613: Insufficient Session Expiration

Source file

pypi/rdiffweb/CVE-2022-3362.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:53 +0000.