Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. qutebrowser
  4. ›
  5. CVE-2018-10895

CVE-2018-10895: Qutebrowser CSRF Vulnerability

October 10, 2018 (updated October 16, 2024)

qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access qute://* URLs. A malicious website could exploit this to load a qute://settings/set URL, which then sets editor.command to a bash script, resulting in arbitrary code execution.

References

  • bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10895
  • github.com/advisories/GHSA-wgmx-52ph-qqcw
  • github.com/pypa/advisory-database/tree/main/vulns/qutebrowser/PYSEC-2018-27.yaml
  • github.com/qutebrowser/qutebrowser
  • github.com/qutebrowser/qutebrowser/commit/43e58ac865ff862c2008c510fc5f7627e10b4660
  • nvd.nist.gov/vuln/detail/CVE-2018-10895

Code Behaviors & Features

Detect and mitigate CVE-2018-10895 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.4.1

Fixed versions

  • 1.4.1

Solution

Upgrade to version 1.4.1 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

pypi/qutebrowser/CVE-2018-10895.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:10 +0000.