Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. pywb
  4. ›
  5. CVE-2021-39286

CVE-2021-39286: Cross-site scripting in pywb

September 2, 2021 (updated October 25, 2024)

Webrecorder pywb before 2.6.0 allows XSS because it does not ensure that Jinja2 templates are autoescaped.

References

  • github.com/advisories/GHSA-947x-pv47-pp3q
  • github.com/pypa/advisory-database/tree/main/vulns/pywb/PYSEC-2021-120.yaml
  • github.com/webrecorder/pywb
  • github.com/webrecorder/pywb/commit/f7bd84cdacdd665ff73ae8d09a202f60be2ebae9
  • github.com/webrecorder/pywb/compare/v-2.5.0...v-2.6.0
  • nvd.nist.gov/vuln/detail/CVE-2021-39286

Code Behaviors & Features

Detect and mitigate CVE-2021-39286 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.6.0

Fixed versions

  • 2.6.0

Solution

Upgrade to version 2.6.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/pywb/CVE-2021-39286.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:15 +0000.