Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. python-json-logger
  4. ›
  5. CVE-2025-27607

CVE-2025-27607: Potential RCE via missing `msgspec-python313-pre` dependency

March 7, 2025 (updated June 20, 2025)

Between 30 December 2024 and 4 March 2025 Python JSON Logger was vulnerable to RCE through a missing dependency.

References

  • github.com/nhairs/python-json-logger/security/advisories/GHSA-wmxh-pxcx-9w24
  • nvd.nist.gov/vuln/detail/CVE-2025-27607

Code Behaviors & Features

Detect and mitigate CVE-2025-27607 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 3.2.0 before 3.3.0

Fixed versions

  • 3.3.0

Solution

Upgrade to version 3.3.0 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-829: Inclusion of Functionality from Untrusted Control Sphere

Source file

pypi/python-json-logger/CVE-2025-27607.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:57 +0000.