Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. python-gnupg
  4. ›
  5. CVE-2014-1927

CVE-2014-1927: python-gnupg's shell_quote function does not properly quote strings

November 6, 2018 (updated October 25, 2024)

The shell_quote function in python-gnupg 0.3.5 does not properly quote strings, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using “$(” command-substitution sequences, a different vulnerability than CVE-2014-1928. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

References

  • bitbucket.org/vinay.sajip/python-gnupg
  • code.google.com/p/python-gnupg
  • code.google.com/p/python-gnupg/issues/detail?id=98
  • github.com/advisories/GHSA-r3vr-prwv-86g9
  • github.com/pypa/advisory-database/tree/main/vulns/python-gnupg/PYSEC-2014-90.yaml
  • nvd.nist.gov/vuln/detail/CVE-2014-1927

Code Behaviors & Features

Detect and mitigate CVE-2014-1927 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.3.5 before 0.3.6, version 0.3.5

Fixed versions

  • 0.3.6

Solution

Upgrade to version 0.3.6 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/python-gnupg/CVE-2014-1927.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:16 +0000.