Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. python-apt
  4. ›
  5. CVE-2019-15795

CVE-2019-15795: Use of a Broken or Risky Cryptographic Algorithm

May 24, 2022 (updated August 14, 2023)

python-apt only checks the MD5 sums of downloaded files in Version.fetch_binary() and Version.fetch_source() of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.

References

  • github.com/advisories/GHSA-rp8m-h266-53jh
  • nvd.nist.gov/vuln/detail/CVE-2019-15795
  • usn.ubuntu.com/4247-1/
  • usn.ubuntu.com/4247-3/

Code Behaviors & Features

Detect and mitigate CVE-2019-15795 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 0.7.8

Solution

Unfortunately, there is no solution available yet.

Impact 4.7 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-327: Use of a Broken or Risky Cryptographic Algorithm

Source file

pypi/python-apt/CVE-2019-15795.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:41 +0000.