Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. pyOpenSSL
  4. ›
  5. CVE-2018-1000807

CVE-2018-1000807: PyOpenSSL Use-After-Free vulnerability

October 10, 2018 (updated October 15, 2024)

It was discovered that pyOpenSSL incorrectly handled memory when handling X509 objects. A remote attacker could use this issue to cause pyOpenSSL to crash, resulting in a denial of service, or possibly execute arbitrary code. This attack appears to be exploitable via Depends on the calling application and if it retains a reference to the memory. This vulnerability appears to have been fixed in 17.5.0.

References

  • access.redhat.com/errata/RHSA-2019:0085
  • github.com/advisories/GHSA-p28m-34f6-967q
  • github.com/pyca/pyopenssl
  • github.com/pyca/pyopenssl/commit/e73818600065821d588af475b024f4eb518c3509
  • github.com/pyca/pyopenssl/pull/723
  • github.com/pypa/advisory-database/tree/main/vulns/pyopenssl/PYSEC-2018-23.yaml
  • nvd.nist.gov/vuln/detail/CVE-2018-1000807
  • usn.ubuntu.com/3813-1

Code Behaviors & Features

Detect and mitigate CVE-2018-1000807 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 17.5.0

Fixed versions

  • 17.5.0

Solution

Upgrade to version 17.5.0 or above.

Impact 8.1 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-416: Use After Free

Source file

pypi/pyOpenSSL/CVE-2018-1000807.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:24 +0000.