Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. pykerberos
  4. ›
  5. CVE-2015-3206

CVE-2015-3206: python-kerberos vulnerable to KDC spoofing attacks

May 14, 2022 (updated September 27, 2024)

The checkPassword function in python-kerberos does not authenticate the KDC it attempts to communicate with, which allows remote attackers to cause a denial of service (bad response), or have other unspecified impact by performing a man-in-the-middle attack.

References

  • bugzilla.redhat.com/show_bug.cgi?id=1223802
  • github.com/advisories/GHSA-mffc-9gx5-99g3
  • github.com/apple/ccs-pykerberos
  • github.com/apple/ccs-pykerberos/commit/9cb61c93f9b24dd18a0a315f3df5445529c5c333
  • github.com/apple/ccs-pykerberos/issues/31
  • github.com/pypa/advisory-database/tree/main/vulns/kerberos/PYSEC-2017-49.yaml
  • github.com/pypa/advisory-database/tree/main/vulns/pykerberos/PYSEC-2017-66.yaml
  • nvd.nist.gov/vuln/detail/CVE-2015-3206
  • pypi.python.org/pypi/kerberos
  • web.archive.org/web/20150910143429/https://trac.calendarserver.org/ticket/833
  • web.archive.org/web/20200228090829/http://www.securityfocus.com/bid/74760

Code Behaviors & Features

Detect and mitigate CVE-2015-3206 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.1.6

Fixed versions

  • 1.1.6

Solution

Upgrade to version 1.1.6 or above.

Impact 8.1 HIGH

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

pypi/pykerberos/CVE-2015-3206.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:21 +0000.