Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. pygit2
  4. ›
  5. CVE-2018-10887

CVE-2018-10887: Out-of-bounds Read

July 10, 2018 (updated October 9, 2019)

The libgit2 library, which is used by pygit2, is vulnerable to an integer overflow which leads to an out-of-bound read. An attacker may use this flaw to leak memory addresses or cause a Denial of Service.

References

  • bugzilla.redhat.com/show_bug.cgi?id=1598021
  • nvd.nist.gov/vuln/detail/CVE-2018-10887

Code Behaviors & Features

Detect and mitigate CVE-2018-10887 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.27.3

Fixed versions

  • 0.27.3

Solution

Upgrade to version 0.27.3 or above.

Impact 8.1 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-125: Out-of-bounds Read
  • CWE-190: Integer Overflow or Wraparound
  • CWE-681: Incorrect Conversion between Numeric Types

Source file

pypi/pygit2/CVE-2018-10887.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:18 +0000.