Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. pyftpdlib
  4. ›
  5. CVE-2007-6739

CVE-2007-6739: Improper Input Validation in pyftpdlib

May 1, 2022 (updated October 21, 2024)

FTPServer.py in pyftpdlib before 0.2.0 allows remote attackers to cause a denial of service via a long command.

References

  • github.com/advisories/GHSA-5f3f-pg2c-cxcv
  • github.com/giampaolo/pyftpdlib
  • github.com/giampaolo/pyftpdlib/issues/3
  • github.com/pypa/advisory-database/tree/main/vulns/pyftpdlib/PYSEC-2010-23.yaml
  • nvd.nist.gov/vuln/detail/CVE-2007-6739

Code Behaviors & Features

Detect and mitigate CVE-2007-6739 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.2.0

Fixed versions

  • 0.2.0

Solution

Upgrade to version 0.2.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/pyftpdlib/CVE-2007-6739.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:53 +0000.